Recent Posts

Topics

Archives


« | Main | »

Solution: skype: error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64

By Jesse | May 4, 2009

I recently hit a problem with skype on linux. When running skype from the GUI, nothing happened, I tried running skype from the command line and got :

skype: error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64

apparently due to the fact it was unable to find libasound.so.2 which is provided by the alsa-libs.i386 package. This was further verified by running:

ldd /usr/bin/skype

for those of you unfamilar with ldd, it lists all the pacakge dependencies and whether or not it can find each file, if you have this problem and run this command, you will likely find that for libasound.so.2 you get => not found.

I then ran yum install alsa-lib.i386 but found it was already installed. This quickly led to the solution :: Uninstall alsa then reinstall.. which did indeed fix the problem.

to do this:
yum remove alsa-lib.i386 (this will also uninstall skype)
yum install alsa-lib.i386 (this reinstalls alsa)

then browse to http://www.skype.com/download and download the new rpm.

Let me know if this fixes your problem.

_______________________________________
PLEASE HELP BY BOOKMARKING OUR SITE...
[del.icio.us] [Digg] [StumbleUpon]

Topics: How To, Misc | 1 Comment »

One Response to “Solution: skype: error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64”

  1. Thannoy Says:
    July 22nd, 2010 at 1:42 pm

    Thanks for the tip.
    reading your post, I run this line wich worked without reinstalling skype:

    yum reinstall alsa-lib.i686

    On my FC13.

Comments